应用下载或安装问题

问题

您正在尝试在被管安卓设备上下载并静默安装应用,收到错误消息应用安装失败,或安装似乎正在进行很长时间,或状态更改为已计划重试

原因

应用安装可能仍在进行中或已计划重试的原因如下:

应用安装失败可能的原因如下:

解决方案

已计划重试

要在设备上安装应用,第一步是在启动安装前下载它。如果应用下载失败,MDM将在10分钟内自动重试三次。在所有重试完成前,状态将保持为已计划重试。如果下载成功,应用安装将启动,否则,状态将更改为失败。

正在进行

当多个应用分发到设备时,应用下载和安装将按顺序进行。因此,在下载和安装一个应用时,其他应用将排队等待安装,并且安装状态将保持为正在进行,直到另一个应用的安装完成。

应用安装失败

导致应用安装失败的问题可以通过以下步骤解决:

基于用户

  • 在将应用分发到设备前,确保接受Google Play服务条款

基于设备

  • 确保有足够的空间安装应用。
  • 请确保设备的网络连接正常。
  • 如果设备上开启了数据保护,确保Google Play Store和Google Play Services不在列表中。
  • 通过导航至设置-> 应用与通知-> Google Play Store-> 存储-> 清除数据,清除Google Play Store应用数据和缓存。
  • 对于小米设备,通过导航至设置-> 构建号,关闭MIUI优化。点击构建号7次以启用开发人员选项并禁用MIUI优化。
  • 如果MDM服务器上的备注下显示消息“产品与设备不兼容”,则应用可能与设备不兼容。要验证这一点,您可以使用个人账户访问设备上的Play Store,搜索应用,并检查应用是否安装在设备上。

如果问题仍然存在,请参阅此链接或联系我们的支持团队。

基于账户(仅当已配置被管Google Play

有G Suite
  • 确保配置了安卓 Enterprise的G Suite账户被添加为设备上的工作账户。要添加工作账户,请导航至设备上的设置 -> 账户。如果设备设置为配置文件所有者,请在工作下添加帐户。
  • 确保未启用Google移动管理。要进行验证,请登录到您的Google管理控制台,导航至设备管理 -> 设置 -> 安卓应用管理,然后点击删除链接以禁用作为EMM提供商的Google移动管理。在下一步中启用复选框,然后点击禁用完成该过程。
没有G Suite

如果在没有G Suite的情况下配置被管Google Play,则会向设备中添加一个被管账户。此被管账户是为了方便静默应用管理、Play Store布局定制和其他安卓 Enterprise相关的功能。此账户只能由MDM解决方案使用,用户无权删除此账户或将其用于设备上安装的任何其他应用。

默认情况下,MDM会在配置被管Google Play时尝试在设备上添加被管账户,但有时添加账户可能会失败或持续很长时间,或者可能需要用户干预才能成功完成。管理员可以通过导航至设备管理 -> 应用库 -> 被管Google Play来检查被管账户的状态。用户还可以通过导航至设置 -> 账户来验证设备上是否存在被管账户。如果设备设置为配置文件所有者,则该账户将添加到工作下。

Managed Account on 安卓 Device

被管账户添加失败或仍正在进行的原因如下:

  • 设备上没有Play Store或Play Services,或设备上的Play Store未经验证。在这种情况下,无法在设备上添加被管账户,并且它将不支持安卓 Enterprise相关功能。
  • 某些设备型号仅在登记为设备所有者配置文件所有者时才支持安卓 Enterprise。使用适当的登记方法重新登记设备以启动被管账户添加。
  • 设备上未更新Play Store或Play Services。在某些情况下,Play Store店或Play Services将自动更新,之后将自动启动被管账户添加。否则,用户可以通过在ME MDM应用中导航至违反的策略并按照屏幕上的说明手动更新它。
  • 如果添加被管账户的过程持续很长时间或遇到任何其他错误,请导航至设备管理 -> 应用库 -> 被管Google Play,点击无被管账户的设备数,然后点击重试。建议等待一段时间,确保设备可以访问,然后点击“重试”。

如果问题仍然存在(即使在多次重试后),请联系支持团队并附上日志

基于Play Store(仅当已配置Android For Work时)

  • 在设备上打开Play Store(或Play Store for Work,如果作为配置文件所有者),确保已添加Play Store账户。如果提示,接受条款和条件
  • 如果在Play Store中添加了多个Google账户(个人账户和工作账户),请确保选择了工作账户,或根据需要切换到工作账户。
  • 另一个选项是取消批准Play for Work上已批准的应用,然后批准该应用并重试。
  • 在静默应用安装/更新的情况下,应用添加到队列最多需要24小时,如此处所述。

基于位置

当关联的设备在应用分发期间移动到不同的地理区域时,安装应用可能会失败,因为该应用是特定于国家/地区的。分发之前,请确保该应用在您所在的地区可用,这有助于避免安装过程中出现错误。

基于APK

不兼容应用:下载分发的应用时,如果收到报错“设备不兼容”,请使用个人账户在Play Store中手动安装该应用,以验证该应用是否与您的设备型号兼容。

安装企业应用失败的原因如下:

  • 应用签名不匹配:当旧应用和新应用中的签名不同时。
  • 应用不能降级:当设备上有最新版本的应用时。
  • 损坏的APK:当设备无法读取APK的内容时。
  • APK中的权限冲突:当旧应用和新应用之间的权限存在冲突时。

尝试使用应用库中添加的APK在设备上手动安装应用。如果应用无法安装,那么问题在于APK文件。

基于服务器

由于服务器时间不正确,应用安装可能会失败。服务器时间需要与本地标准时间匹配。如果不匹配,请更改计算机的日期和时间设置,然后重启服务器。

如果问题仍然存在,请尝试重新分发应用或联系MDM支持团队并附上日志。

适用于:应用管理、静默安装、管理移动设备
关键词:应用安装失败、移动设备管理、应用管理